summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-06-02 17:43:43 -0700
committerEric Anholt <eric@anholt.net>2010-06-24 15:05:21 -0700
commit0161515c395c44233529c8d51f823b60050bc7ba (patch)
tree519436e6362c0b705258d6a408ae762a5a4e9002 /Makefile.am
parent224f712950494730c76b48864f2ca19acde1c8cf (diff)
ir_to_mesa: Remove the BURG code.
The promise of the BURG was to recognize multi-instruction sequences and emit reduced sequences for them. It would have worked well for recognizing MUL+ADD -> MAD and possibly even MIN(MAX(val, 0), 1) -> MOV_SAT with some grammar changes. However, that potential benefit in making those optimizations easy is outweighed by the fragility of monoburg, the amount of (incorrect, as I wrote it) code for using it, and the burden it was going to cause for handling operations on aggregate types.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 0 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index bf062595a9..c34f7d8abf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,16 +63,11 @@ glsl_SOURCES = \
ir_validate.cpp \
ir_vec_index_to_swizzle.cpp \
linker.cpp \
- mesa_codegen.cpp \
- msea_codegen.h \
mesa/shader/prog_instruction.c \
mesa/shader/prog_instruction.h \
mesa/shader/prog_print.c \
mesa/shader/prog_print.h
-DISTFILES = \
- mesa_codegen.brg
-
BUILT_SOURCES = glsl_parser.h glsl_parser.cpp glsl_lexer.cpp
CLEANFILES = $(BUILT_SOURCES)
@@ -82,8 +77,3 @@ glsl_parser.h: glsl_parser.cpp
.lpp.cpp:
$(LEXCOMPILE) --outfile="$@" $<
-
-mesa_codegen.h: mesa_codegen.cpp
-
-mesa_codegen.cpp: mesa_codegen.brg
- monoburg --no-glib -s $@ -d mesa_codegen.h $<