summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-06-24 15:21:51 -0700
committerEric Anholt <eric@anholt.net>2010-06-24 15:27:10 -0700
commit0ee7d80269bfab14683623b0c8fc12da43db8d78 (patch)
tree7b2a65190c9934ed8a0ff02f2845323c420153a3 /Makefile.am
parent6b01b50888d22ee330df44240591051cb55cf2a9 (diff)
parent8364fc85b8273b4d0f2ecebe7e0085e250d29990 (diff)
Merge branch 'mesa'
This brings in the ir_to_mesa.cpp code I've been developing to codegen to the Mesa IR. It does not actually generate a complete Mesa fragment/vertex program yet.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a88bf0022a..c34f7d8abf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,6 +21,7 @@
# USE OR OTHER DEALINGS IN THE SOFTWARE.
AUTOMAKE_OPTIONS = foreign
+AM_CPPFLAGS = -I mesa
SUBDIRS = glcpp
@@ -57,9 +58,15 @@ glsl_SOURCES = \
ir_hierarchical_visitor.h \
ir_hierarchical_visitor.cpp \
ir_swizzle_swizzle.cpp \
+ ir_to_mesa.cpp \
+ ir_to_mesa.h \
ir_validate.cpp \
ir_vec_index_to_swizzle.cpp \
- linker.cpp
+ linker.cpp \
+ mesa/shader/prog_instruction.c \
+ mesa/shader/prog_instruction.h \
+ mesa/shader/prog_print.c \
+ mesa/shader/prog_print.h
BUILT_SOURCES = glsl_parser.h glsl_parser.cpp glsl_lexer.cpp
CLEANFILES = $(BUILT_SOURCES)