summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2010-03-30 16:56:50 -0700
committerIan Romanick <ian.d.romanick@intel.com>2010-03-30 16:56:50 -0700
commit1cf43a4331dfe62aaa834e5bc6319b43eac98445 (patch)
tree9f7f27618e1e6d5aacdc149f57b22a1f90ff30fd /Makefile.am
parent84960f01cb0edb79ec86d120b7dab7f254373940 (diff)
Initial bits of constant expression evaluator
Currently only works for constants. The rest will be added later.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9f5efa9e5d..c1c96ba2b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,7 +27,8 @@ glsl_SOURCES = symbol_table.c hash_table.c glsl_types.cpp \
glsl_parser.ypp glsl_lexer.lpp glsl_parser_extras.cpp \
ast_expr.cpp ast_to_hir.cpp ast_function.cpp ast_type.cpp \
ir.cpp hir_field_selection.cpp builtin_function.cpp \
- ir_print_visitor.cpp ir_variable.cpp ir_function.cpp
+ ir_print_visitor.cpp ir_variable.cpp ir_function.cpp \
+ ir_constant_expression.cpp
BUILT_SOURCES = glsl_parser.h builtin_types.h glsl_parser.cpp glsl_lexer.cpp
CLEANFILES = $(BUILT_SOURCES)