summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-04-14 17:03:03 -0700
committerEric Anholt <eric@anholt.net>2010-04-14 17:05:13 -0700
commit5ba94206083fcd678febd6cac0231f35c0f1b77a (patch)
tree79311ea6e69d971c8a8c34a7624da4a9f203b2c1 /Makefile.am
parent60be7626b829af7e1d07330b9a88468924ba350e (diff)
Add an ir_if simplification pass.
This is relatively simple at the moment, recognizing only constant values, and not (for example) values that are restricted to a range that make the branching constant. However, it does remove 59 lines from the printout of CorrectParse2.vert.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6fac0a8c4c..68a1d98d33 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,7 +30,8 @@ glsl_SOURCES = symbol_table.c hash_table.c glsl_types.cpp \
ir_print_visitor.cpp ir_variable.cpp ir_function.cpp \
ir_constant_expression.cpp \
ir_constant_folding.cpp \
- ir_function_inlining.cpp
+ ir_function_inlining.cpp \
+ ir_if_simplification.cpp
BUILT_SOURCES = glsl_parser.h builtin_types.h glsl_parser.cpp glsl_lexer.cpp
CLEANFILES = $(BUILT_SOURCES)