summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-05-12 12:10:41 -0700
committerEric Anholt <eric@anholt.net>2010-06-01 15:15:04 -0700
commit65122e9e8038488e8c586eb609e434a90188de27 (patch)
treea0ec2cf6a753017b69961ef18caa9c9f8948fb1c /Makefile.am
parentf389862006dde5b0d4bcf36ba85364a1ef6d4a5d (diff)
ir_constant_variable: New pass to mark constant-assigned variables constant.
This removes a bunch of gratuitous moving around of constant values from constructors. Makes a shader ir I was looking at for structure handling almost readable.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 986b6fecd4..a62591d9ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,6 +34,7 @@ glsl_SOURCES = \
ir_basic_block.h \
ir_constant_expression.cpp \
ir_constant_folding.cpp \
+ ir_constant_variable.cpp \
ir_copy_propagation.cpp \
ir_copy_propagation.h \
ir_dead_code.cpp \