summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2010-03-09 16:23:37 -0800
committerIan Romanick <ian.d.romanick@intel.com>2010-03-09 16:26:15 -0800
commit78b51b0fdd61b58940f9043ef9046217552f2c70 (patch)
tree61f60182a78feec1288f97fc1f78b6d921ae6b19 /Makefile.am
parentfce1150156edc8b51f5cf077679c0fdb5d582aba (diff)
IR visitor: Add initial version of ir_visitor classes
The ir_visitor class is the abstract base class for all visitors. ir_print_visitor contains the beginnings of a concrete visitor class that will print out an IR sequence in a Lisp / Scheme-like syntax.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 77b401357a..60317f8b4d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,7 +25,8 @@ AUTOMAKE_OPTIONS = foreign
bin_PROGRAMS = glsl
glsl_SOURCES = symbol_table.c hash_table.c glsl_types.cpp \
glsl_parser.ypp glsl_lexer.lpp glsl_parser_extras.cpp \
- ast_expr.cpp ast_to_hir.cpp ir.cpp hir_field_selection.cpp
+ ast_expr.cpp ast_to_hir.cpp ir.cpp hir_field_selection.cpp \
+ ir_print_visitor.cpp
BUILT_SOURCES = glsl_parser.h builtin_types.h