summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-04-16 16:43:47 -0700
committerEric Anholt <eric@anholt.net>2010-04-19 15:33:52 -0700
commit7d21104a8b92c139051e9a224c5d863802a8ade6 (patch)
tree9fbd9d256c6bd64063439c0adfbd95ec5561a64d /Makefile.am
parent71df19f5ef6e78beb5160801f81468184b75447e (diff)
Remove dead code assignments and variable declarations.
This pass only works on assignments where the variable is never referenced. There is no code flow analysis, so it can't do a better job of avoiding redundant assignments. For now, the optimizer only does do_dead_code_unlinked(), so it won't trim the builtin variable list or initializers outside of the scope of functions. This is because we don't have the visibility into other functions that might get linked in in order to eliminate work on global variables.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ef1a0266b..80b5c2ec68 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,6 +30,7 @@ glsl_SOURCES = symbol_table.c hash_table.c glsl_types.cpp \
ir_print_visitor.cpp ir_variable.cpp ir_function.cpp \
ir_constant_expression.cpp \
ir_constant_folding.cpp \
+ ir_dead_code.cpp \
ir_expression_flattening.cpp \
ir_function_inlining.cpp \
ir_if_simplification.cpp