summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-04-29 09:02:09 -0700
committerEric Anholt <eric@anholt.net>2010-06-24 15:05:19 -0700
commit84771df82ed2ed8718013795089edd38cf5bd84d (patch)
tree44ef28d26546dc7375a22c357f350acc40b77a69 /Makefile.am
parent9290e0dd28e646c3dc810e0a6405582f8bf643b6 (diff)
ir_to_mesa: Start building GLSL IR to Mesa IR conversion.
There are major missing pieces here. Most operations aren't supported. Matrices need to be broken down to vector ops before we get here. Scalar operations (RSQ, RCP) are handled incorrectly. Arrays and structures are not even considered.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a88bf0022a..88d8f0587c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,6 +21,7 @@
# USE OR OTHER DEALINGS IN THE SOFTWARE.
AUTOMAKE_OPTIONS = foreign
+AM_CPPFLAGS = -I mesa
SUBDIRS = glcpp
@@ -57,9 +58,16 @@ glsl_SOURCES = \
ir_hierarchical_visitor.h \
ir_hierarchical_visitor.cpp \
ir_swizzle_swizzle.cpp \
+ ir_to_mesa.cpp \
+ ir_to_mesa.h \
ir_validate.cpp \
ir_vec_index_to_swizzle.cpp \
- linker.cpp
+ linker.cpp \
+ mesa_codegen.cpp \
+ msea_codegen.h
+
+DISTFILES = \
+ mesa_codegen.brg
BUILT_SOURCES = glsl_parser.h glsl_parser.cpp glsl_lexer.cpp
CLEANFILES = $(BUILT_SOURCES)
@@ -70,3 +78,8 @@ glsl_parser.h: glsl_parser.cpp
.lpp.cpp:
$(LEXCOMPILE) --outfile="$@" $<
+
+mesa_codegen.h: mesa_codegen.cpp
+
+mesa_codegen.cpp: mesa_codegen.brg
+ monoburg --no-glib -s $@ -d mesa_codegen.h $<