summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-04-23 13:24:20 -0700
committerIan Romanick <ian.d.romanick@intel.com>2010-04-23 16:12:44 -0700
commit8d3e59f1f399d7c1f7604779f1d62e876c609d9e (patch)
tree2329ea89fd95671af0aaf5e918393adbe0cb7330 /Makefile.am
parent82ad90f8cf0860a4065f3a4ece6dc66b1e408c12 (diff)
Replace builtin_types.h generation with the generated output.
The script to generate it was longer and more obfuscated than the output.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 80b5c2ec68..8fb74dcee8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,9 @@
AUTOMAKE_OPTIONS = foreign
bin_PROGRAMS = glsl
-glsl_SOURCES = symbol_table.c hash_table.c glsl_types.cpp \
+glsl_SOURCES = \
+ builtin_types.h \
+ symbol_table.c hash_table.c glsl_types.cpp \
glsl_parser.ypp glsl_lexer.lpp glsl_parser_extras.cpp \
ast_expr.cpp ast_to_hir.cpp ast_function.cpp ast_type.cpp \
ir.cpp hir_field_selection.cpp builtin_function.cpp \
@@ -35,13 +37,10 @@ glsl_SOURCES = symbol_table.c hash_table.c glsl_types.cpp \
ir_function_inlining.cpp \
ir_if_simplification.cpp
-BUILT_SOURCES = glsl_parser.h builtin_types.h glsl_parser.cpp glsl_lexer.cpp
+BUILT_SOURCES = glsl_parser.h glsl_parser.cpp glsl_lexer.cpp
CLEANFILES = $(BUILT_SOURCES)
glsl_parser.h: glsl_parser.cpp
.lpp.cpp:
$(LEXCOMPILE) --outfile="$@" $<
-
-builtin_types.h: builtin_types.sh
- bash ./builtin_types.sh > builtin_types.h