summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2010-03-09 15:17:37 -0800
committerIan Romanick <ian.d.romanick@intel.com>2010-03-09 15:49:31 -0800
commiteccf0bf5f2e261b315b2a473667f71cae50c6001 (patch)
tree16ae8d76defea299918afb477d6d78edbb14cdd4 /Makefile.am
parent3a9e989628e37a0122ff72c8ef52e82dcb5ff41a (diff)
Make glsl_type a class
Among other benefits, this cleans up a the hackery invovled in initializing the union field in builtin_types.h.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1fc8aa97a2..77b401357a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,7 @@
AUTOMAKE_OPTIONS = foreign
bin_PROGRAMS = glsl
-glsl_SOURCES = symbol_table.c hash_table.c glsl_types.c \
+glsl_SOURCES = symbol_table.c hash_table.c glsl_types.cpp \
glsl_parser.ypp glsl_lexer.lpp glsl_parser_extras.cpp \
ast_expr.cpp ast_to_hir.cpp ir.cpp hir_field_selection.cpp