summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-03-23 20:43:10 -0700
committerEric Anholt <eric@anholt.net>2010-03-23 12:32:25 -0700
commitf41fc537280d048bca2a3b23abd17d8bb3eff907 (patch)
treee0384f2196d5257d6be9086fa24aac64ff256fa8 /Makefile.am
parente5ba18083b20da540ea0dc216e744a4c3e550833 (diff)
Include other generated sources in BUILT_SOURCES.
Otherwise, having cleaned glsl_parser.h, we'd never regenerate it because glsl_parser.cpp was already right where it needed to be.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f299c3fc4f..48b4b3921c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,10 +29,10 @@ glsl_SOURCES = symbol_table.c hash_table.c glsl_types.cpp \
ir.cpp hir_field_selection.cpp \
ir_print_visitor.cpp ir_variable.cpp ir_function.cpp
-BUILT_SOURCES = glsl_parser.h builtin_types.h
+BUILT_SOURCES = glsl_parser.h builtin_types.h glsl_parser.cpp glsl_lexer.cpp
CLEANFILES = $(BUILT_SOURCES)
-glsl_parser.h: glsl_parser.ypp
+glsl_parser.h: glsl_parser.cpp
.lpp.cpp:
$(LEXCOMPILE) --outfile="$@" $<