summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-02-21 10:17:19 -0800
committerDan Nicholson <dbn.lists@gmail.com>2008-02-21 10:19:55 -0800
commit112a40ec0280756d83ac9145fd5908d6ffb12e4c (patch)
treedc0aeaf84fc43f455a8f12a4480c226120b62723 /configure.ac
parent4e9c8166b064de4eed38e385880cd491e6d8d9c4 (diff)
autoconf: Set the default drivers after checking platform specifics
The platform-specific overrides to the DRI drivers were being ignored because the default was being set first. Instead, have the default be a fallback after the platform checks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 19f9fcfcb0..e67cd542a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -459,12 +459,6 @@ if test "$mesa_driver" = dri; then
PROGRAM_DIRS="egl"
fi
- # default drivers
- if test "x$DRI_DIRS" = x; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v \
- savage sis tdfx trident unichrome ffb"
- fi
-
# Platform specific settings and drivers to build
case "$host_os" in
linux*)
@@ -513,6 +507,13 @@ if test "$mesa_driver" = dri; then
fi
;;
esac
+
+ # default drivers
+ if test "x$DRI_DIRS" = x; then
+ DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v \
+ savage sis tdfx trident unichrome ffb"
+ fi
+
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`
# Check for expat