summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-03-24 10:01:50 -0700
committerDan Nicholson <dbn.lists@gmail.com>2008-03-31 17:00:00 -0700
commitb645942df9779f44089029de8832928b21746173 (patch)
tree4e1305ffd465478b5e89b39b39b686775fbc3a47 /configure.ac
parent3ea80c1128344a06b5d5c9cd45615a597047e402 (diff)
Use AC_CHECK_PROGS to find alternate make programs
The autoconf macro AC_PATH_PROGS handles the case of searching for multiple program names already, so we don't need to open code it. Also changed the search to AC_CHECK_PROGS so that it doesn't set the full path unless the user specified. Finally, report back the found value at the end for what the user should run.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index ac4b77cef0..8598a0d2d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,11 +26,7 @@ dnl Check for progs
AC_PROG_CPP
AC_PROG_CC
AC_PROG_CXX
-AC_PATH_PROG(GMAKE, gmake, [not_found])
-AC_PATH_PROG(MAKE, make)
-if test "x$GMAKE" != "xnot_found"; then
- MAKE="$GMAKE"
-fi
+AC_CHECK_PROGS(MAKE, [gmake make])
AC_PATH_PROG(MKDEP, makedepend)
AC_PATH_PROG(SED, sed)
@@ -903,5 +899,5 @@ echo " CXXFLAGS: $cxxflags"
echo " Macros: $defines"
echo ""
-echo " Run 'make' to build Mesa"
+echo " Run '${MAKE-make}' to build Mesa"
echo ""