summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-06-21 11:29:15 -0700
committerEric Anholt <eric@anholt.net>2010-06-24 17:23:21 -0700
commit0a1b54df7ac118722bb627c61cb322cb4e248ace (patch)
treec01794fe2833bbfa38a24e975d000ee00804271a /configure.ac
parent3d6012303c3ce24c75d209267e6914f706d025c5 (diff)
glsl2: Replace the GLSL compiler with the glsl2 project.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 21123ecccc..bf42992b2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -462,6 +462,8 @@ xxlib|xdri|xosmesa)
;;
esac
+PKG_CHECK_MODULES([TALLOC], [talloc])
+
dnl
dnl Driver specific build directories
dnl
@@ -852,7 +854,7 @@ if test "$mesa_driver" = dri; then
[AC_MSG_ERROR([Expat required for DRI.])])
# put all the necessary libs together
- DRI_LIB_DEPS="$SELINUX_LIBS $LIBDRM_LIBS $EXPAT_LIB -lm -lpthread $DLOPEN_LIBS"
+ DRI_LIB_DEPS="$SELINUX_LIBS $LIBDRM_LIBS $EXPAT_LIB -lm -lpthread $DLOPEN_LIBS $TALLOC_LIBS"
fi
AC_SUBST([DRI_DIRS])
AC_SUBST([EXPAT_INCLUDES])