summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-04-27 13:42:33 -0400
committerKristian Høgsberg <krh@bitplanet.net>2010-04-28 14:36:28 -0400
commit0f68032a7cebe740421e5de4586d13c99a8728ab (patch)
tree1900e2d5b346b4c2a2f79694b2db35608587e017 /configure.ac
parent5efee4d4e68067a3fd85b9ff6a2636f502538768 (diff)
configure.ac: Add options to enable GLES1/2 API support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0e77707433..abb655135f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -711,6 +711,37 @@ if test "x$with_dri_drivers" = x; then
with_dri_drivers=no
fi
+dnl Determine which APIs to support
+AC_ARG_ENABLE([opengl],
+ [AS_HELP_STRING([--disable-opengl],
+ [disable support for standard OpenGL API @<:@default=no@:>@])],
+ [enable_opengl="$enableval"],
+ [enable_opengl=yes])
+AC_ARG_ENABLE([gles1],
+ [AS_HELP_STRING([--enable-gles1],
+ [enable support for OpenGL ES 1.x API @<:@default=no@:>@])],
+ [enable_gles1="$enableval"],
+ [enable_gles1=no])
+AC_ARG_ENABLE([gles2],
+ [AS_HELP_STRING([--enable-gles2],
+ [enable support for OpenGL ES 2.x API @<:@default=no@:>@])],
+ [enable_gles2="$enableval"],
+ [enable_gles2=no])
+
+API_DEFINES=""
+if test "x$enable_opengl" = xno; then
+ API_DEFINES="$API_DEFINES -DFEATURE_GL=0"
+else
+ API_DEFINES="$API_DEFINES -DFEATURE_GL=1"
+fi
+if test "x$enable_gles1" = xyes; then
+ API_DEFINES="$API_DEFINES -DFEATURE_ES1=1"
+fi
+if test "x$enable_gles2" = xyes; then
+ API_DEFINES="$API_DEFINES -DFEATURE_ES2=1"
+fi
+AC_SUBST([API_DEFINES])
+
dnl If $with_dri_drivers is yes, directories will be added through
dnl platform checks
DRI_DIRS=""