summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarek Olšák <maraeo@gmail.com>2010-09-28 19:32:32 +0200
committerMarek Olšák <maraeo@gmail.com>2010-09-28 19:38:40 +0200
commit11eb422a161153da6226042d0fea561161e4f292 (patch)
tree4144ab150e610f801a606ae52682bd63b78b1a3c /configure.ac
parenta1aec2e2be3222d4b8b8391fa25551643774d833 (diff)
configure.ac: do not build xorg-r300g by default
NOTE: This is a candidate for the 7.9 branch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ca16edff50..364ee03947 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1532,14 +1532,22 @@ AC_ARG_ENABLE([gallium-radeon],
[build gallium radeon @<:@default=disabled@:>@])],
[enable_gallium_radeon="$enableval"],
[enable_gallium_radeon=auto])
-if test "x$enable_gallium_radeon" = xyes || test "x$enable_gallium_radeon" = xauto; then
+if test "x$enable_gallium_radeon" = xauto; then
if test "x$HAVE_LIBDRM_RADEON" = xyes; then
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r300"
- gallium_check_st "radeon/drm" "dri-r300" "xorg-radeon"
+ gallium_check_st "radeon/drm" "dri-r300"
else
AC_MSG_WARN([libdrm_radeon is missing, not building gallium-radeon (r300)])
fi
fi
+if test "x$enable_gallium_radeon" = xyes; then
+ if test "x$HAVE_LIBDRM_RADEON" = xyes; then
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r300"
+ gallium_check_st "radeon/drm" "dri-r300" "xorg-radeon"
+ else
+ AC_MSG_ERROR([libdrm_radeon is missing, cannot build gallium-radeon (r300)])
+ fi
+fi
dnl
dnl Gallium Radeon r600g configuration