summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2010-10-30 14:26:01 +0800
committerChia-I Wu <olv@lunarg.com>2010-10-30 14:41:17 +0800
commit156e955c25ad4acd78d683c4def83769f0bb3ddb (patch)
treed4cfd4022715cfc0f100aff73e0843db69eaa8eb /configure.ac
parentcff1aeea10c6d8520cbb17381d81a684b2e9408b (diff)
autoconf: st/vega requires --enable-openvg.
Make it a warning for now to smooth the transition.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 860ea21ca7..53f938c702 100644
--- a/configure.ac
+++ b/configure.ac
@@ -493,6 +493,16 @@ AC_ARG_ENABLE([openvg],
[enable_openvg="$enableval"],
[enable_openvg=no])
+dnl smooth the transition; should be removed eventually
+if test "x$enable_openvg" = xno; then
+ case "x$with_state_trackers" in
+ x*vega*)
+ AC_MSG_WARN([vega state tracker is enabled without --enable-openvg])
+ enable_openvg=yes
+ ;;
+ esac
+fi
+
if test "x$enable_opengl" = xno -a \
"x$enable_gles1" = xno -a \
"x$enable_gles2" = xno -a \
@@ -1398,6 +1408,11 @@ yes)
PKG_CHECK_MODULES([LIBKMS_XORG], [libkms >= $LIBKMS_XORG_REQUIRED])
HAVE_ST_XORG="yes"
;;
+ vega)
+ if test "x$enable_openvg" != xyes; then
+ AC_MSG_ERROR([cannot build vega state tracker without --enable-openvg])
+ fi
+ ;;
esac
if test -n "$tracker"; then