summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosé Fonseca <jfonseca@vmware.com>2011-03-14 19:58:22 +0000
committerJosé Fonseca <jfonseca@vmware.com>2011-03-14 20:05:56 +0000
commit202c345c7cf5074c0d0be208067c072c2f53535a (patch)
treeda4f627f4102dec54ca0977eea49f1c5345f0421 /configure.ac
parent25e31140952c328f70f804e0134664d7ed6248a6 (diff)
autoconf/make: Don't specify individual llvm libraries.
We need more and more of these, and it is difficult and prone to version incompatability issues trying to single out every one of them. This mimicks what was done in SCons.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 70380ff931..b5101519e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1649,7 +1649,7 @@ if test "x$enable_gallium_llvm" = xyes; then
if test "x$LLVM_CONFIG" != xno; then
LLVM_VERSION=`$LLVM_CONFIG --version`
LLVM_CFLAGS=`$LLVM_CONFIG --cppflags`
- LLVM_LIBS="`$LLVM_CONFIG --libs jit interpreter nativecodegen bitwriter x86disassembler` -lstdc++"
+ LLVM_LIBS="`$LLVM_CONFIG --libs` -lstdc++"
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS llvmpipe"