summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2010-09-19 17:31:34 +0800
committerChia-I Wu <olv@lunarg.com>2010-09-19 17:35:04 +0800
commit2a910b339672e80e70d49d01ac7e8e870068e7ad (patch)
tree58059a49fdbdd73bdee6383d7b927ec2b8b6cc6f /configure.ac
parente4513e7fb96c6336d8c7fcdadfaddb6b335a736e (diff)
egl: Enable drm platform by default.
This enables EGL_MESA_drm_display for st/egl in the default setup.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b19bf8fdf2..cf743ba9bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1376,6 +1376,9 @@ case "$with_egl_platforms" in
yes)
if test "x$enable_egl" = xyes && test "x$mesa_driver" != xosmesa; then
EGL_PLATFORMS="x11"
+ if test "$mesa_driver" = dri; then
+ EGL_PLATFORMS="$EGL_PLATFORMS drm"
+ fi
fi
;;
*)