summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKenneth Graunke <kenneth@whitecape.org>2010-10-25 13:52:58 -0700
committerKenneth Graunke <kenneth@whitecape.org>2010-10-27 12:49:53 -0700
commit3acc8265200295265b476222299a013791050b73 (patch)
tree4811cef085bbc52c51581036deca14a361d93502 /configure.ac
parent676c3f08bd13564c088ae85c3538ee0ee3c52599 (diff)
Fix build on systems where "python" is python 3.
First, it changes autoconf to use a "python2" binary when available, rather than plain "python" (which is ambiguous). Secondly, it changes the Makefiles to use $(PYTHON) $(PYTHON_FLAGS) rather than calling python directly. Signed-off-by: Xavier Chantry <chantry.xavier@gmail.com> Signed-off-by: Matthew William Cox <matt@mattcox.ca> Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 364ee03947..d6f15b5c34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,7 @@ AC_PROG_CPP
AC_PROG_CC
AC_PROG_CXX
AC_CHECK_PROGS([MAKE], [gmake make])
+AC_CHECK_PROGS([PYTHON2], [python2 python])
AC_PATH_PROG([MKDEP], [makedepend])
AC_PATH_PROG([SED], [sed])
@@ -1691,6 +1692,8 @@ echo ""
echo " CFLAGS: $cflags"
echo " CXXFLAGS: $cxxflags"
echo " Macros: $defines"
+echo ""
+echo " PYTHON2: $PYTHON2"
echo ""
echo " Run '${MAKE-make}' to build Mesa"