summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Fogal <tfogal@alumni.unh.edu>2011-02-21 22:32:18 -0700
committerTom Fogal <tfogal@alumni.unh.edu>2011-02-23 10:40:26 -0700
commit4484297505431cfa9d0360f888ea4fb4194c698a (patch)
tree4dbc74104c20d8f8bb1f0c284d8d42fd94b1e30a /configure.ac
parent0ed5bf668db24fb56b5b359399099c89531e2a0a (diff)
Fix GLX_USE_TLS define.
It was only getting set in the case of DRI drivers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e1702ba200..fbc743650c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -890,6 +890,9 @@ AC_ARG_ENABLE([glx-tls],
[GLX_USE_TLS=no])
AC_SUBST(GLX_TLS, ${GLX_USE_TLS})
+AS_IF([test "x$GLX_USE_TLS" = xyes],
+ [DEFINES="${DEFINES} -DGLX_USE_TLS -DPTHREADS"])
+
dnl
dnl More DRI setup
dnl
@@ -945,11 +948,6 @@ esac
dnl Set DRI_DIRS, DEFINES and LIB_DEPS
if test "$mesa_driver" = dri -o "$mesa_driver" = no; then
- # Use TLS in GLX?
- if test "x$GLX_USE_TLS" = xyes; then
- DEFINES="$DEFINES -DGLX_USE_TLS -DPTHREADS"
- fi
-
# Platform specific settings and drivers to build
case "$host_os" in
linux*)