summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-03-02 21:23:04 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-03-02 20:41:38 +0100
commit4ca075ac4f047141d5e5ef865991650e0ac488e4 (patch)
tree7c8c8ff9ed3ca3efd7a4accd4cc8ade79bd1c227 /configure.ac
parent648a16d079282a33289d9b1d91108a665bd84547 (diff)
egl_dri2 x11: Workaround device_name xcb-dri2 bug
This commit is basically a copy-over of the fix Chia-I Wu's commited to wayland: http://cgit.freedesktop.org/wayland/wayland-demos/commit/?id=1b6c0ed95 "Workaround an xcb-dri2 bug. xcb_dri2_connect_device_name generated by xcb-proto 1.6 is broken. It only works when the length of the driver name is a multiple of 4."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9fa5eeea18..d33ca301f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1162,6 +1162,9 @@ if test "x$enable_egl" = xyes; then
if test "$have_libudev" = yes; then
DEFINES="$DEFINES -DHAVE_LIBUDEV"
fi
+ # workaround a bug in xcb-dri2 generated by xcb-proto 1.6
+ AC_CHECK_LIB(xcb-dri2, xcb_dri2_connect_alignment_pad, [],
+ [DEFINES="$DEFINES -DXCB_DRI2_CONNECT_DEVICE_NAME_BROKEN"])
fi
fi