summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakob Bornecrantz <wallbraker@gmail.com>2010-03-25 18:29:51 +0100
committerJakob Bornecrantz <wallbraker@gmail.com>2010-03-26 00:37:52 +0100
commit5b1fc14627ae37c5def70e2d5fe28bf7a4becee6 (patch)
tree7eaabe33aa89be31e78a4c1f56f367287d0623ab /configure.ac
parenta6fecdff3e71f080d4caf29d2b0713ab5ce9d5f4 (diff)
st/dri: Reshuffle files and make it obvious which files are shared
In short: git mv ../drisw/Makefile dri/sw git mv drisw.[c|h] sw git mv dri2.[c|h] dri1.[c|h] Makefile drm git rm ../drisw ln -s <common files> drm/* ln -s <common files> sw/*
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index d6d952d7a5..caa2cf6576 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1204,9 +1204,8 @@ yes)
GALLIUM_STATE_TRACKERS_DIRS=glx
;;
dri)
- GALLIUM_STATE_TRACKERS_DIRS="dri drisw"
+ GALLIUM_STATE_TRACKERS_DIRS="dri"
HAVE_ST_DRI="yes"
- HAVE_ST_DRISW="yes"
if test "x$enable_egl" = xyes; then
GALLIUM_STATE_TRACKERS_DIRS="$GALLIUM_STATE_TRACKERS_DIRS egl"
HAVE_ST_EGL="yes"
@@ -1232,12 +1231,6 @@ yes)
fi
HAVE_ST_DRI="yes"
;;
- drisw)
- if test "x$mesa_driver" != xdri; then
- AC_MSG_ERROR([cannot build drisw state tracker without mesa driver set to dri])
- fi
- HAVE_ST_DRISW="yes"
- ;;
egl)
if test "x$enable_egl" != xyes; then
AC_MSG_ERROR([cannot build egl state tracker without EGL library])
@@ -1409,7 +1402,7 @@ AC_ARG_ENABLE([gallium-swrast],
[enable_gallium_swrast="$enableval"],
[enable_gallium_swrast=auto])
if test "x$enable_gallium_swrast" = xyes || test "x$enable_gallium_swrast" = xauto; then
- if test "x$HAVE_ST_DRISW" = xyes; then
+ if test "x$HAVE_ST_DRI" = xyes; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS dri-swrast"
fi
if test "x$HAVE_ST_EGL" = xyes; then