summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJerome Glisse <jglisse@redhat.com>2010-11-15 14:53:21 -0500
committerJerome Glisse <jglisse@redhat.com>2010-11-15 14:56:40 -0500
commit5da246944a787b933a509f0b65bab466574c3339 (patch)
tree8f58c7701dd866f31e80615ce4512b005aa5d4b4 /configure.ac
parent88850b3e4f5f2692bf77d46fab031bd573f4d642 (diff)
gallium/noop: no operation gallium driver
This driver is a fake swdri driver that perform no operations beside allocation gallium structure and buffer for upper layer usage. It's purpose is to help profiling core mesa/gallium without having pipe driver overhead hidding hot spot of core code. scons file are likely inadequate i am unfamiliar with this build system. To use it simply rename is to swrast_dri.so and properly set LIBGL_DRIVERS_PATH env variable. Signed-off-by: Jerome Glisse <jglisse@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b43a9fd1e8..77e7603520 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1708,6 +1708,19 @@ if test "x$enable_gallium_swrast" = xyes || test "x$enable_gallium_swrast" = xau
fi
fi
+dnl
+dnl Gallium noop configuration
+dnl
+AC_ARG_ENABLE([gallium-noop],
+ [AS_HELP_STRING([--enable-gallium-noop],
+ [build gallium radeon @<:@default=disabled@:>@])],
+ [enable_gallium_noop="$enableval"],
+ [enable_gallium_noop=auto])
+if test "x$enable_gallium_noop" = xyes; then
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS noop"
+ GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS dri-noop"
+fi
+
dnl prepend CORE_DIRS to SRC_DIRS
SRC_DIRS="$CORE_DIRS $SRC_DIRS"