summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-04-30 13:28:03 -0700
committerDan Nicholson <dbn.lists@gmail.com>2008-04-30 13:31:44 -0700
commit80f68e1b6a0e5bd2da799c659c963e213dbf9e66 (patch)
treefa2d3d36e9af9e4cabd8b0ca249bc5e5513029fb /configure.ac
parentd12fa3511da23d8285f3ea1a51a1f328cdbb1462 (diff)
autoconf: Don't substitute MESA_MAJOR and friends
Since the autoconf config inherits from default, we don't need to duplicate and substitute the MESA_* version numbers in configure.ac. The version number is only needed in configure for the help text.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 8f5f0a7cef..43111b3062 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,24 +4,13 @@ AC_PREREQ(2.59)
dnl Versioning
dnl Make version number available to autoconf and configure
-m4_define(mesa_major, 7)
-m4_define(mesa_minor, 1)
-m4_define(mesa_tiny, 0)
-m4_define(mesa_version, [mesa_major().mesa_minor().mesa_tiny()])
+m4_define([mesa_version],[7.1.0])
AC_INIT([Mesa],[mesa_version()],
[https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa])
AC_CONFIG_AUX_DIR(bin)
AC_CANONICAL_HOST
-dnl Substitute the version number into shell variables
-MESA_MAJOR=mesa_major()
-MESA_MINOR=mesa_minor()
-MESA_TINY=mesa_tiny()
-AC_SUBST(MESA_MAJOR)
-AC_SUBST(MESA_MINOR)
-AC_SUBST(MESA_TINY)
-
dnl Check for progs
AC_PROG_CPP
AC_PROG_CC