summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2010-10-29 12:34:44 +0800
committerChia-I Wu <olv@lunarg.com>2010-10-29 12:42:24 +0800
commit815faa448cccc38aebb1b60ecf0bd7e6bf8f277e (patch)
treeb0a4687e8d2a8540028d9c2c82fb059a8326f025 /configure.ac
parentc6320c5eb20d1ab20ad7800aceedc5dd8762dfeb (diff)
autoconf: Update configuration info.
Output API info first. Move GLU/GLw/GLUT and EGL near driver info.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac63
1 files changed, 40 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index d1a9fefdf6..860ea21ca7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1706,25 +1706,51 @@ echo " exec_prefix: $exec_prefix"
echo " libdir: $libdir"
echo " includedir: $includedir"
+dnl API info
+echo ""
+echo " OpenGL: $enable_opengl (ES1: $enable_gles1 ES2: $enable_gles2)"
+echo " GLES overlay: $enable_gles_overlay"
+echo " OpenVG: $enable_openvg"
+
dnl Driver info
echo ""
echo " Driver: $mesa_driver"
-if echo "$DRIVER_DIRS" | grep 'osmesa' >/dev/null 2>&1; then
- echo " OSMesa: lib$OSMESA_LIB"
-else
- echo " OSMesa: no"
-fi
-if test "$mesa_driver" = dri; then
- # cleanup the drivers var
- dri_dirs=`echo $DRI_DIRS | $SED 's/^ *//;s/ */ /;s/ *$//'`
-if test "x$DRI_DIRS" = x; then
- echo " DRI drivers: no"
-else
- echo " DRI drivers: $dri_dirs"
+if test "$mesa_driver" != no; then
+ if echo "$DRIVER_DIRS" | grep 'osmesa' >/dev/null 2>&1; then
+ echo " OSMesa: lib$OSMESA_LIB"
+ else
+ echo " OSMesa: no"
+ fi
+ if test "$mesa_driver" = dri; then
+ # cleanup the drivers var
+ dri_dirs=`echo $DRI_DIRS | $SED 's/^ *//;s/ */ /;s/ *$//'`
+ if test "x$DRI_DIRS" = x; then
+ echo " DRI drivers: no"
+ else
+ echo " DRI drivers: $dri_dirs"
+ fi
+ echo " DRI driver dir: $DRI_DRIVER_INSTALL_DIR"
+ echo " Use XCB: $enable_xcb"
+ fi
fi
- echo " DRI driver dir: $DRI_DRIVER_INSTALL_DIR"
+echo ""
+echo " GLU: $enable_glu"
+echo " GLw: $enable_glw (Motif: $enable_motif)"
+echo " glut: $enable_glut"
+
+dnl EGL
+echo ""
+echo " EGL: $enable_egl"
+if test "$enable_egl" = yes; then
+ echo " EGL platforms: $EGL_PLATFORMS"
+ echo " EGL drivers: $EGL_DRIVERS_DIRS"
+ if test "$enable_gallium" = yes -a "$HAVE_ST_EGL" = yes; then
+ echo " EGL tracker: yes"
+ echo " EGL client APIs:$EGL_CLIENT_APIS"
+ else
+ echo " EGL tracker: no"
+ fi
fi
-echo " Use XCB: $enable_xcb"
echo ""
if test "x$MESA_LLVM" = x1; then
@@ -1754,15 +1780,6 @@ dnl Libraries
echo ""
echo " Shared libs: $enable_shared"
echo " Static libs: $enable_static"
-if test "$enable_egl" = yes; then
- echo " EGL: $EGL_DRIVERS_DIRS"
- echo " EGL platforms: $EGL_PLATFORMS"
-else
- echo " EGL: no"
-fi
-echo " GLU: $enable_glu"
-echo " GLw: $enable_glw (Motif: $enable_motif)"
-echo " glut: $enable_glut"
dnl Compiler options
# cleanup the CFLAGS/CXXFLAGS/DEFINES vars