summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2010-05-12 14:17:17 +0800
committerChia-I Wu <olv@lunarg.com>2010-05-12 15:03:42 +0800
commit87cc2da16ef2c32813eee9c9c8af3c919f4739d9 (patch)
tree8fae12c282f657ff2558b8a16a2a861b414de6e2 /configure.ac
parent8d5c83c467f83b44f5f2e271c4f9cca2d45af518 (diff)
mesa/es: Merge back to core mesa.
With the omit list gone, there are not too many differences in building core mesa and ES overlay. Remove the mesa/es and build both of them in src/mesa/Makefile.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3207c9f718..4acc6d5bac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -757,6 +757,7 @@ AC_ARG_ENABLE([gles-overlay],
API_DEFINES=""
APIS=""
+GLES_OVERLAY=0
if test "x$enable_opengl" = xno; then
API_DEFINES="$API_DEFINES -DFEATURE_GL=0"
else
@@ -775,11 +776,12 @@ if test "x$enable_gles_overlay" = xyes -o \
"x$enable_gles1" = xyes -o "x$enable_gles2" = xyes; then
CORE_DIRS="mapi/es1api mapi/es2api $CORE_DIRS"
if test "x$enable_gles_overlay" = xyes; then
- CORE_DIRS="$CORE_DIRS mesa/es"
+ GLES_OVERLAY=1
fi
fi
AC_SUBST([API_DEFINES])
AC_SUBST([APIS])
+AC_SUBST([GLES_OVERLAY])
dnl If $with_dri_drivers is yes, directories will be added through
dnl platform checks
@@ -1331,7 +1333,7 @@ yes)
if test "x$enable_gles1" != xyes -a "x$enable_gles2" != xyes; then
CORE_DIRS="mapi/es1api mapi/es2api $CORE_DIRS"
fi
- CORE_DIRS="$CORE_DIRS mesa/es"
+ GLES_OVERLAY=1
EGL_CLIENT_APIS="$EGL_CLIENT_APIS "'$(GLESv1_CM_LIB) $(GLESv2_LIB)'
fi
tracker=""