summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Hein <5qgu8gvshg@snkmail.com>2010-07-01 12:53:28 -0700
committerDan Nicholson <dbn.lists@gmail.com>2010-07-01 13:00:02 -0700
commit9617254a1e5522615c96ab25c9e0a70e0d63d7e7 (patch)
tree1cd858151bd2d2551fbe778cf3d511afcf6b86f9 /configure.ac
parentd2fe97a209134ff5267e8aa065865c3398bfb280 (diff)
Use GLUT_CFLAGS when building glut
Fix this build error (in MesaGLUT-7.6.1)... glut_cmap.c:23:66: error: X11/Xmu/StdCmap.h: No such file or directory ...by not preventing the cflags that pkg-config finds for glut dependencies (including 'xmu') from being used. Defining GLUT_CFLAGS before running the pkg-config prevents the cflags found by pkg-config from being used. This patch lets GLUT_CFLAGS that configure & pkg-config work so hard to set actually get used. Also make sure the generated configs/autoconf defines GLUT_CFLAGS used in (at least) src/glut/glx/Makefile. Signed-off-by: Dan Nicholson <dbn.lists@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7583ab8595..16fd1e43bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1118,10 +1118,6 @@ fi
if test "x$enable_glut" = xyes; then
SRC_DIRS="$SRC_DIRS glut/glx"
- GLUT_CFLAGS=""
- if test "x$GCC" = xyes; then
- GLUT_CFLAGS="-fexceptions"
- fi
if test "$x11_pkgconfig" = yes; then
PKG_CHECK_MODULES([GLUT],[x11 xmu xi])
GLUT_PC_REQ_PRIV="x11 xmu xi"
@@ -1132,6 +1128,9 @@ if test "x$enable_glut" = xyes; then
GLUT_PC_LIB_PRIV="$GLUT_LIB_DEPS"
GLUT_PC_CFLAGS="$X11_INCLUDES"
fi
+ if test "x$GCC" = xyes; then
+ GLUT_CFLAGS="$GLUT_CFLAGS -fexceptions"
+ fi
GLUT_LIB_DEPS="$GLUT_LIB_DEPS -lm"
GLUT_PC_LIB_PRIV="$GLUT_PC_LIB_PRIV -lm"