summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2010-03-03 15:59:37 -0800
committerIan Romanick <ian.d.romanick@intel.com>2010-03-03 16:26:32 -0800
commit9aa3aa71386394725ce88df463d6183f62777ee5 (patch)
treeb00bde44f8a134a2968183458e028c99fffdece4 /configure.ac
parent3594bf233d16ceb21e97fcdfb57ea45cb0c5e41b (diff)
Add version check for GCC
Mesa now requires GCC 3.3.0 or later. See the following thread from the mesa3d-dev mailing list for more details: http://marc.info/?t=126748568900005&r=1&w=2 Signed-off-by: Ian Romanick <ian.d.romanick@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e807d4acaf..8ca274932c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,28 @@ solaris*)
;;
esac
+dnl If we're using GCC, make sure that it is at least version 3.3.0. Older
+dnl versions are explictly not supported.
+if test "x$GCC" = xyes; then
+ AC_MSG_CHECKING([whether gcc version is sufficient])
+ major=0
+ minor=0
+
+ GCC_VERSION=`$CC -dumpversion`
+ if test $? -eq 0; then
+ major=`echo $GCC_VERSION | cut -d. -f1`
+ minor=`echo $GCC_VERSION | cut -d. -f1`
+ fi
+
+ if test $major -lt 3 -o $major -eq 3 -a $minor -lt 3 ; then
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([If using GCC, version 3.3.0 or later is required.])
+ else
+ AC_MSG_RESULT([yes])
+ fi
+fi
+
+
MKDEP_OPTIONS=-fdepend
dnl Ask gcc where it's keeping its secret headers
if test "x$GCC" = xyes; then