summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-05-02 10:14:53 -0400
committerKristian Høgsberg <krh@bitplanet.net>2010-05-02 10:14:53 -0400
commit9fd5fa05122aa0cac0051fa92d1634bde43209db (patch)
tree0b24a39fc2cec3195fefd879e3d39bcfa543961d /configure.ac
parent74399d4af5b5ea793ce8318c10014a026cf81563 (diff)
Hook in install rules for es1 and es2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8e25163f75..01f511749c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -743,21 +743,26 @@ AC_ARG_ENABLE([gles2],
[enable_gles2=no])
API_DEFINES=""
+APIS=""
if test "x$enable_opengl" = xno; then
API_DEFINES="$API_DEFINES -DFEATURE_GL=0"
else
API_DEFINES="$API_DEFINES -DFEATURE_GL=1"
+ APIS="$APIS gl"
fi
if test "x$enable_gles1" = xyes; then
API_DEFINES="$API_DEFINES -DFEATURE_ES1=1"
+ APIS="$APIS es1"
fi
if test "x$enable_gles2" = xyes; then
API_DEFINES="$API_DEFINES -DFEATURE_ES2=1"
+ APIS="$APIS es2"
fi
if test "x$enable_gles1" = xyes -o "x$enable_gles2"; then
SRC_DIRS="$SRC_DIRS gles"
fi
AC_SUBST([API_DEFINES])
+AC_SUBST([APIS])
dnl If $with_dri_drivers is yes, directories will be added through
dnl platform checks