summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-08-30 14:19:23 -0700
committerEric Anholt <eric@anholt.net>2010-08-30 14:20:05 -0700
commita3c2bd416aa871166baacff50c89842e3b533d9b (patch)
tree192c931edf8d78f155306470bef2e01efabd50e2 /configure.ac
parent2a50187a923eb8950bc8b63f50eaea4704d6dc36 (diff)
Don't pass -ffast-math to clang, since it ignores it and complains.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cf2e200db3..77004cc881 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,7 +137,10 @@ esac
dnl Add flags for gcc and g++
if test "x$GCC" = xyes; then
- CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -std=c99 -ffast-math"
+ CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -std=c99"
+ if test "x$CLANG" = "xno"; then
+ CFLAGS="$CFLAGS -ffast-math"
+ fi
# Enable -fvisibility=hidden if using a gcc that supports it
save_CFLAGS="$CFLAGS"