summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2011-01-04 01:05:22 +0800
committerChia-I Wu <olv@lunarg.com>2011-01-04 01:13:49 +0800
commitada9c78c29ef11720d464211c098b740f8aa11a4 (patch)
treecb3d207356f99d3b22c58d89f864a9b553696777 /configure.ac
parentcba77869547f8edb1c1fdafcf457bccc4097042b (diff)
autoconf: Fix --with-driver=xlib --enable-openvg.
st/egl should be enabled with --enable-openvg even the driver is xlib or osmesa. Also, GLX_DIRECT_RENDERING should not be defined because libdrm is not checked.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index bd81775305..b451f7cc16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1352,7 +1352,7 @@ if test "x$enable_gallium_egl" = xauto; then
enable_gallium_egl=$enable_egl
;;
*)
- enable_gallium_egl=no
+ enable_gallium_egl=$enable_openvg
;;
esac
fi
@@ -1467,10 +1467,6 @@ AC_SUBST([EGL_CLIENT_APIS])
if test "x$HAVE_ST_EGL" = xyes; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS egl"
- # define GLX_DIRECT_RENDERING even when the driver is not dri
- if test "x$mesa_driver" != xdri -a "x$driglx_direct" = xyes; then
- DEFINES="$DEFINES -DGLX_DIRECT_RENDERING"
- fi
fi
if test "x$HAVE_ST_XORG" = xyes; then