summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakob Bornecrantz <wallbraker@gmail.com>2010-05-13 20:29:18 +0100
committerJerome Glisse <jglisse@redhat.com>2010-05-27 23:24:12 +0200
commitaeee52691ccb3afd24591ab3df30d7f243bc3eeb (patch)
treef4785fea68b2541f9e5eedb2147ebe7096e5b549 /configure.ac
parent9abfc5ef60ba26505a333bdd0f17a83c90ce316a (diff)
r600g: Integrate into build
Signed-off-by: Jakob Bornecrantz <wallbraker@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3d8da6c979..db4f6d740e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1510,6 +1510,19 @@ elif test "x$enable_gallium_radeon" = xauto; then
fi
dnl
+dnl Gallium Radeon r600g configuration
+dnl
+AC_ARG_ENABLE([gallium-r600],
+ [AS_HELP_STRING([--enable-gallium-r600],
+ [build gallium radeon @<:@default=disabled@:>@])],
+ [enable_gallium_r600="$enableval"],
+ [enable_gallium_r600=auto])
+if test "x$enable_gallium_r600" = xyes; then
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r600"
+ gallium_check_st "r600/drm" "dri-r600"
+fi
+
+dnl
dnl Gallium Nouveau configuration
dnl
AC_ARG_ENABLE([gallium-nouveau],