summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2010-07-16 19:39:58 +0800
committerChia-I Wu <olv@lunarg.com>2010-07-16 19:41:29 +0800
commitbb217ba76a9c3823e074ec7708f07233a85eb4ac (patch)
tree8e20f280f30712e964c4d1962c4bec91444d9c9b /configure.ac
parent6f6c8ec7b724c088ce087d866d7eadabe95633c3 (diff)
egl: Build egl_dri2 only when xcb-dri2 is available.
The driver does not build when xcb-dri2 is not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f52c6db65a..1b116ae50e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -970,12 +970,11 @@ if test "x$enable_egl" = xyes; then
if test "$have_xcb_dri2" = yes; then
EGL_DRIVER_DRI2=dri2
DEFINES="$DEFINES -DHAVE_XCB_DRI2"
+ if test "$have_libudev" = yes; then
+ DEFINES="$DEFINES -DHAVE_LIBUDEV"
+ fi
fi
- if test "$have_libudev" = yes; then
- EGL_DRIVER_DRI2=dri2
- DEFINES="$DEFINES -DHAVE_LIBUDEV"
- fi
EGL_DRIVERS_DIRS="$EGL_DRIVERS_DIRS $EGL_DRIVER_DRI2"
fi