summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2011-01-20 14:19:13 +0800
committerChia-I Wu <olv@lunarg.com>2011-01-20 15:04:34 +0800
commitc116a0e2dcce7635707fab724cfe4f6bc23906e3 (patch)
treec8b159d43724a916dae78d37650898bd97777695 /configure.ac
parent21148e6a8806736b4487da41b01e2d3c01cbc743 (diff)
autoconf: Fail when --with-state-trackers is incomplete.
When --enable-openvg or --enable-gallium-egl is enabled, --with-state-trackers must have vega or egl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d9220c86b5..f51ad9edc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1428,6 +1428,7 @@ yes)
if test "x$enable_openvg" != xyes; then
AC_MSG_ERROR([cannot build vega state tracker without --enable-openvg])
fi
+ have_st_vega="yes"
;;
esac
@@ -1442,6 +1443,14 @@ yes)
fi
done
GALLIUM_STATE_TRACKERS_DIRS="$state_trackers"
+
+ # append --enable-openvg/--enable-gallium-egl to --with-state-trackers
+ if test "x$have_st_vega" != xyes -a "x$enable_openvg" = xyes; then
+ AC_MSG_ERROR([--with-state-trackers specified but vega is missing])
+ fi
+ if test "x$HAVE_ST_EGL" != xyes -a "x$enable_gallium_egl" = xyes; then
+ AC_MSG_ERROR([--with-state-trackers specified but egl is missing])
+ fi
;;
esac