summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2010-05-02 14:09:52 -0400
committerKristian Høgsberg <krh@bitplanet.net>2010-05-02 14:09:52 -0400
commitda76a4d845367242c1ae7726d1dc23900f31e1e4 (patch)
treeff45a40eb51a1020f6782e4b44bdddbfec38854e /configure.ac
parent559d124ed3f2070c73c5cb9c3b506ddd9cfaeb02 (diff)
mesa: Only compile ES files when ES1 or ES2 are selected
This still requieres manual generation of the es1 and es2 glapis and is disabled by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2811ec9e40..ef8a7eef82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -745,6 +745,8 @@ AC_ARG_ENABLE([gles2],
API_DEFINES=""
APIS=""
+ES1_SOURCES=""
+ES2_SOURCES=""
if test "x$enable_opengl" = xno; then
API_DEFINES="$API_DEFINES -DFEATURE_GL=0"
else
@@ -754,16 +756,20 @@ fi
if test "x$enable_gles1" = xyes; then
API_DEFINES="$API_DEFINES -DFEATURE_ES1=1"
APIS="$APIS es1"
+ ES1_SOURCES='$(ES1_SOURCES)'
fi
if test "x$enable_gles2" = xyes; then
API_DEFINES="$API_DEFINES -DFEATURE_ES2=1"
APIS="$APIS es2"
+ ES2_SOURCES='$(ES2_SOURCES)'
fi
if test "x$enable_gles1" = xyes -o "x$enable_gles2"; then
SRC_DIRS="$SRC_DIRS gles"
fi
AC_SUBST([API_DEFINES])
AC_SUBST([APIS])
+AC_SUBST([ES1_SOURCES])
+AC_SUBST([ES2_SOURCES])
dnl If $with_dri_drivers is yes, directories will be added through
dnl platform checks