summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-02-04 12:22:58 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-02-07 13:52:29 +0100
commite586c4b7634f856a350f029709adc8a32271562c (patch)
tree98c9e0b4c81b7c14048c732a7bf5e98a9b459a7b /configure.ac
parent2adfde3aaee43d7ec974d25794a07fe02f36c6cd (diff)
egl: Add wayland platform
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9c6ce3f215..67cdb15755 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1536,6 +1536,10 @@ yes)
if test "$plat" = "fbdev"; then
GALLIUM_WINSYS_DIRS="$GALLIUM_WINSYS_DIRS sw/fbdev"
fi
+ if test "$plat" = "wayland"; then
+ PKG_CHECK_MODULES([WAYLAND], [wayland-client],, \
+ [AC_MSG_ERROR([cannot find libwayland-client])])
+ fi
done
EGL_PLATFORMS="$egl_platforms"
;;