summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-07-06 14:17:39 -0700
committerDan Nicholson <dbn.lists@gmail.com>2008-07-06 14:17:54 -0700
commite6e4f25aa5433fc77a3c1b0dba2300cc4cee5d33 (patch)
tree9803182a51a3e91f7485c4f6a29791c30b3957ba /configure.ac
parent11ac5b2456575060627e9f52946d7d0e218a228d (diff)
autoconf: Allow commas or spaces to separate DRI drivers
Explicitly allow the argument to --with-dri-drivers to contain comma-separated or space-separated drivers. A space-separated driver list worked by chance before.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 961a60cccf..a2ebc3b3b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -619,7 +619,7 @@ case "$with_dri_drivers" in
no|yes) ;;
*)
# verify the requested driver directories exist
- dri_drivers=`IFS=,; echo $with_dri_drivers`
+ dri_drivers=`IFS=', '; echo $with_dri_drivers`
for driver in $dri_drivers; do
test -d "$srcdir/src/mesa/drivers/dri/$driver" || \
AC_MSG_ERROR([DRI driver directory '$driver' doesn't exist])