summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuca Barbieri <luca@luca-barbieri.com>2010-09-24 10:10:09 +0200
committerLuca Barbieri <luca@luca-barbieri.com>2010-09-27 14:10:18 +0200
commitf762f7b85d11314915cb420d21a062dd597f8ff8 (patch)
treeec6b8ecc8d83d787a627e77fa2f93f37c079eef3 /configure.ac
parent4c6344f569c5417b0ea804f6f8216a2b40321480 (diff)
mesa: make makedepend an hard requirement
Currently makedepend is used by the Mesa Makefile-based build system, but not required. Unfortunately, not having it makes dependency resolution non-existent, which is a source of subtle bugs, and is a rarely tested configuration, since all Mesa developers likely have it installed. Furthermore some idioms require dependency resolution to work at all, such as making headers depend on generated files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b8296dcc6..e75224d748 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,10 @@ AC_CHECK_PROGS([MAKE], [gmake make])
AC_PATH_PROG([MKDEP], [makedepend])
AC_PATH_PROG([SED], [sed])
+if test "x$MKDEP" = "x"; then
+ AC_MSG_ERROR([makedepend is required to build Mesa])
+fi
+
dnl Our fallback install-sh is a symlink to minstall. Use the existing
dnl configuration in that case.
AC_PROG_INSTALL