summaryrefslogtreecommitdiff
path: root/docs/MESA_resize_buffers.spec
diff options
context:
space:
mode:
authorBrian Paul <brian.paul@tungstengraphics.com>1999-07-20 00:30:41 +0000
committerBrian Paul <brian.paul@tungstengraphics.com>1999-07-20 00:30:41 +0000
commit3e07e16ac7ae5035e78df74240eab346b823694c (patch)
tree629cdaeaaf19463f3f3a14c3d4eddf7f305d635c /docs/MESA_resize_buffers.spec
parent99412b9f1e58d030cf94aae43171439c1875bfbd (diff)
initial rev
Diffstat (limited to 'docs/MESA_resize_buffers.spec')
-rw-r--r--docs/MESA_resize_buffers.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/docs/MESA_resize_buffers.spec b/docs/MESA_resize_buffers.spec
new file mode 100644
index 0000000000..8c0b033ff2
--- /dev/null
+++ b/docs/MESA_resize_buffers.spec
@@ -0,0 +1,82 @@
+Name
+
+ MESA_resize_buffers
+
+Name Strings
+
+ GL_MESA_resize_buffers
+
+Contact
+
+ Brian Paul, brianp 'at' mesa3d.org
+
+Status
+
+ Shipping (since Mesa version 2.2)
+
+Version
+
+ $Id: MESA_resize_buffers.spec,v 1.1 1999/07/20 00:30:41 brianp Exp $
+
+Number
+
+ XXX none assigned
+
+Dependencies
+
+ Mesa 2.2 or later is required.
+
+Overview
+
+ Mesa is often used as a client library with no integration with
+ the computer's window system (an X server, for example). And since
+ Mesa does not have an event loop nor window system callbacks, it
+ cannot properly respond to window system events. In particular,
+ Mesa cannot automatically detect when a window has been resized.
+
+ Mesa's glViewport command queries the current window size and updates
+ its internal data structors accordingly. This normally works fine
+ since most applications call glViewport in responce to window size
+ changes.
+
+ In some situations, however, the application may not call glViewport
+ when a window size changes but would still like Mesa to adjust to
+ the new window size. This extension exports a new function to solve
+ this problem.
+
+New Procedures and Functions
+
+ void glResizeBuffersMESA( void )
+
+New Tokens
+
+ none
+
+Additions to the OpenGL Specification (no particular section)
+
+ The glResizeBuffersMESA command may be called when the client
+ determines that a window has been resized. Calling
+ glResizeBuffersMESA causes Mesa to query the current window size
+ and adjust its internal data structures. This may include
+ reallocating depth, stencil, alpha and accumulation buffers.
+
+Additions to the AGL/GLX/WGL Specifications
+
+ None
+
+Errors
+
+ INVALID_OPERATION is generated if ResizeBuffersMESA is called betweeen
+ Begin and End.
+
+New State
+
+ None.
+
+New Implementation Dependent State
+
+ None.
+
+Revision History
+
+ * Revision 1.0 - Initial specification