summaryrefslogtreecommitdiff
path: root/docs/MESA_ycbcr_texture.spec
diff options
context:
space:
mode:
authorBrian Paul <brian.paul@tungstengraphics.com>2003-05-02 15:05:02 +0000
committerBrian Paul <brian.paul@tungstengraphics.com>2003-05-02 15:05:02 +0000
commit7357f20b1ee3ab0c58c7a20f44bf83fdfe0e256e (patch)
tree514cb30570ebf23bae7ce298b504d1f22382cf97 /docs/MESA_ycbcr_texture.spec
parentc784d87b0f07590a2bb87307ca6a264b2ec99b31 (diff)
minor updates
Diffstat (limited to 'docs/MESA_ycbcr_texture.spec')
-rw-r--r--docs/MESA_ycbcr_texture.spec15
1 files changed, 8 insertions, 7 deletions
diff --git a/docs/MESA_ycbcr_texture.spec b/docs/MESA_ycbcr_texture.spec
index a0ef310dc6..1fbb1e135c 100644
--- a/docs/MESA_ycbcr_texture.spec
+++ b/docs/MESA_ycbcr_texture.spec
@@ -33,9 +33,9 @@ Overview
This extension supports texture images in the YCbCr format. There is
no support for converting YCbCr images to RGB or vice versa. The
- intention is for YCbCr image data to be directly sent to the renderer
- without any pixel transfer operations. Only 2D texture images are
- supported (not glDrawPixels, glReadPixels, etc).
+ texture's YCbCr colors are converted to RGB during texture sampling.
+ Only 2D texture images are supported (not glDrawPixels, glReadPixels,
+ etc).
A YCbCr pixel (texel) is a 16-bit unsigned short with two components.
The first component is luminance (Y). For pixels in even-numbered
@@ -61,12 +61,12 @@ New Tokens
Accepted by the <internalFormat> and <format> parameters of
TexImage2D and TexSubImage2D:
- GL_YCBCR_MESA 0x8757
+ YCBCR_MESA 0x8757
Accepted by the <type> parameter of TexImage2D and TexSubImage2D:
- GL_UNSIGNED_SHORT_8_8_MESA 0x85BA /* same as Apple's */
- GL_UNSIGNED_SHORT_8_8_REV_MESA 0x85BB /* same as Apple's */
+ UNSIGNED_SHORT_8_8_MESA 0x85BA /* same as Apple's */
+ UNSIGNED_SHORT_8_8_REV_MESA 0x85BB /* same as Apple's */
Additions to Chapter 2 of the OpenGL 1.4 Specification (OpenGL Operation)
@@ -181,7 +181,7 @@ Errors
<internalFormat> is MESA_YCBCR and <border> is not zero.
INVALID_OPERATION is generated by TexSubImage2D if the internal image
- format is YCBCR_MESA and format is not YCBCR_MESA.
+ format is YCBCR_MESA and <format> is not YCBCR_MESA.
INVALID_OPERATION is generated by CopyTexSubImage2D if the internal
image is YCBCR_MESA.
@@ -195,3 +195,4 @@ New State
Revision History
20 September 2002 - Initial draft
+ 29 April 2003 - minor updates