summaryrefslogtreecommitdiff
path: root/glcpp/Makefile.am
diff options
context:
space:
mode:
authorKenneth Graunke <kenneth@whitecape.org>2010-06-16 12:18:00 -0700
committerKenneth Graunke <kenneth@whitecape.org>2010-06-21 11:31:54 -0700
commit04ba86a536d76ef24c749e16c785c1634b9187c9 (patch)
treeb9b1d64f0c45a59d8b1e192a3ab363df915ee14e /glcpp/Makefile.am
parent2848c4c183ea0aaca2ca0a23a13196c786403a5c (diff)
Make the main compiler call the preprocessor.
By using a single function, the main compiler doesn't need to include glcpp.h, which currently has a lot of details about the preprocessor internals. In particular, this prevents the two yacc grammars from seeing each other, which would be rather messy to sort out.
Diffstat (limited to 'glcpp/Makefile.am')
-rw-r--r--glcpp/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/glcpp/Makefile.am b/glcpp/Makefile.am
index 26b769ca60..a49fd615cd 100644
--- a/glcpp/Makefile.am
+++ b/glcpp/Makefile.am
@@ -26,6 +26,7 @@ libglcpp_la_SOURCES = \
glcpp-parse.y \
glcpp.h \
hash_table.c \
+ pp.c \
xtalloc.c
BUILT_SOURCES = glcpp-parse.h glcpp-parse.c glcpp-lex.c