summaryrefslogtreecommitdiff
path: root/src/glew/SConscript
diff options
context:
space:
mode:
authorJakob Bornecrantz <jakob@vmware.com>2010-06-05 13:33:58 +0200
committerJakob Bornecrantz <jakob@vmware.com>2010-06-08 02:07:24 +0200
commit0528106cc7a4f87f4920b10d995f881f81ca4154 (patch)
tree01ee11144c4d1a16911c656800d58b417f0882d5 /src/glew/SConscript
parent1574fb78465136b90e42126607a4d39c3db778de (diff)
glew: Drop glew now that we don't need it for the progs
configs/beos | 2 +- configs/darwin | 2 +- configs/default | 4 +- configs/freebsd-dri | 2 +- configs/linux-cell | 2 +- configs/linux-dri-xcb | 2 +- configs/linux-indirect | 2 +- configure.ac | 2 +- include/GL/glew.h |14435 ------------------------------------------------ include/GL/glxew.h | 1476 ----- include/GL/wglew.h | 1247 ----- src/SConscript | 1 - src/glew/LICENSE.txt | 73 - src/glew/Makefile | 54 - src/glew/SConscript | 69 - src/glew/glew.c |14320 ----------------------------------------------- src/glew/glewinfo.c | 8441 ---------------------------- src/glew/visualinfo.c | 1173 ---- 18 files changed, 8 insertions(+), 41299 deletions(-) Revert "glew: update to version 1.5.4" This reverts commit a189b1c53b6a3b6c055cc86145c8ef48c580e9d0. Revert "glew: Include X11 headers and libraries in SCons build." This reverts commit efdd33985cb38429aeae845a556db2322957e71a. Revert "scons: Fix GLEW build on Mac OS X." This reverts commit 8f81769148eab0042ffb7192a702350275648715. Revert "scons: Use static glew library on Unices to avoid binary compatability issues" This reverts commit de22c940a1df66d13825dd15c015eafabb61a11d. Revert "glew: Update to version 1.5.2." This reverts commit aaf7ecfd816f82fef314f4f772cc53bc0ced553e. Revert "scons: Build glew on all platforms." This reverts commit 52eb3e4235cc661ab9626a704c555a5f096c628a. Revert "scons: Put glut and glew shared libraries into build/xxx/bin or lib." This reverts commit 8a318edd0838ee3343be0425019d93541b621567. Didn't revert scons/gallium.py Revert "scons: Fix glew build on MSVC." This reverts commit 14a8c9dac7ea43ad8a45052e17f7127451344e5a. Revert "scons: Build progs together with everything else." This reverts commit 7bbf7f94ea786e41ff1364cedaf7dd5c0bbf605a. Only changed src/glew/SConscript Revert "mesa: include glew headers in MesaDemos tarballs" This reverts commit c57d81ddc9ba3052ff7f6b72091accab2c2db0ae. Revert "mesa: include GLEW sources in MesaDemos tarball" This reverts commit b9e2e32daf5505896a662dc8df60104c0f51b4b9. Revert "glew: correct misspelling of glFramebufferTextureLayer" This reverts commit 1b05b5b4fecd9ac8ef34abdda6c085868016ad84. Revert "glew: fix GLEW_LIB_NAME" This reverts commit c10df26a31b6af5a720fbfd06411d580cd38a2c8. Revert "Add dummy install target for glew to fix 'make install'" This reverts commit c273dfe6a28d4bb64ce167685b4053d22db5a727. Revert "autoconf: Add GLEW needed by progs when building GLUT" This reverts commit 2977cee38e21b8e5ebba1635b101185d64ee44a9. Revert "glew: Build it as a static lib." This reverts commit fcf9353fea8343a1a86c8c6e0144c8429440c648. Revert "glew: Initial import." This reverts commit 57d00016cab9afa3e7853d9830044a8ece9541c4.
Diffstat (limited to 'src/glew/SConscript')
-rw-r--r--src/glew/SConscript69
1 files changed, 0 insertions, 69 deletions
diff --git a/src/glew/SConscript b/src/glew/SConscript
deleted file mode 100644
index 4b5b5b8d0f..0000000000
--- a/src/glew/SConscript
+++ /dev/null
@@ -1,69 +0,0 @@
-Import('*')
-
-# Shared environment settings
-env = env.Clone()
-
-env.PrependUnique(CPPPATH = [
- '#/include',
-])
-
-if env['platform'] == 'windows':
- env.PrependUnique(LIBS = [
- 'glu32',
- 'opengl32',
- 'gdi32',
- 'user32',
- ])
-else:
- env.Tool('x11')
- env.PrependUnique(LIBS = [
- 'GLU',
- 'GL',
- 'X11',
- ])
-
-# Library specific environment settings
-lib_env = env.Clone()
-
-lib_env.Append(CPPDEFINES = [
- 'GLEW_BUILD',
- #'GLEW_MX', # Multiple Rendering Contexts support
-])
-
-if lib_env['platform'] == 'windows':
- target = 'glew'
-else:
- target = 'GLEW'
-
-source = [
- 'glew.c',
-]
-
-if lib_env['platform'] == 'windows':
- glew = lib_env.SharedLibrary(target = target, source = source)
- env.InstallSharedLibrary(glew, version=(1, 5, 2))
- glew = lib_env.FindIxes(glew, 'LIBPREFIX', 'LIBSUFFIX')
-else:
- # Use static library on Unices to avoid binary compatability issues
- lib_env.Append(CPPDEFINES = ['GLEW_STATIC'])
- glew = lib_env.StaticLibrary(target = target, source = source)
-
-# Program specific environment settings
-prog_env = env.Clone()
-
-prog_env.Prepend(LIBS = [glew])
-
-if prog_env['platform'] == 'darwin':
- prog_env.Append(FRAMEWORKS = ['AGL'])
-
-prog_env.Program(
- target = 'glewinfo',
- source = ['glewinfo.c'],
-)
-
-prog_env.Program(
- target = 'visualinfo',
- source = ['visualinfo.c'],
-)
-
-Export('glew')