summaryrefslogtreecommitdiff
path: root/src/glew/SConscript
diff options
context:
space:
mode:
authorBrian Paul <brianp@vmware.com>2009-02-10 16:44:02 -0700
committerBrian Paul <brianp@vmware.com>2009-02-10 16:44:02 -0700
commit5340b6dff73a0a23531ce2a5f28fba8303adab6e (patch)
treeb141fc3648568dd8b941c966059e6ed32a8bd0ad /src/glew/SConscript
parent9fd26daec24f21dbe17afcb2e2ab272667ee9a69 (diff)
parentee4c921b65fb76998711f3c40330505cbc49a0e0 (diff)
Merge commit 'origin/gallium-master-merge'
This is the big merge of the gallium-0.2 branch into master. gallium-master-merge was just the staging area for it. Both gallium-0.2 and gallium-master-merge are considered closed now. Conflicts: progs/demos/Makefile src/mesa/main/state.c src/mesa/main/texenvprogram.c
Diffstat (limited to 'src/glew/SConscript')
-rw-r--r--src/glew/SConscript50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/glew/SConscript b/src/glew/SConscript
new file mode 100644
index 0000000000..1161be6e63
--- /dev/null
+++ b/src/glew/SConscript
@@ -0,0 +1,50 @@
+Import('*')
+
+if env['platform'] not in ['windows', 'linux']:
+ Return()
+
+env = env.Clone()
+
+env.Append(CPPDEFINES = [
+ 'GLEW_BUILD',
+ 'GLEW_STATIC',
+ #'GLEW_MX', # Multiple Rendering Contexts support
+])
+
+env.PrependUnique(CPPPATH = [
+ '#/include',
+])
+
+glew = env.StaticLibrary(
+ target = 'glew',
+ source = [
+ 'glew.c',
+ ],
+)
+
+env = env.Clone()
+
+if env['platform'] == 'windows':
+ env.PrependUnique(LIBS = [
+ 'glu32',
+ 'opengl32',
+ 'gdi32',
+ 'user32',
+ ])
+else:
+ env.PrependUnique(LIBS = [
+ 'GLU',
+ 'GL',
+ 'X11',
+ ])
+env.Prepend(LIBS = [glew])
+
+env.Program(
+ target = 'glewinfo',
+ source = ['glewinfo.c'],
+)
+
+env.Program(
+ target = 'visualinfo',
+ source = ['visualinfo.c'],
+)