summaryrefslogtreecommitdiff
path: root/src/glsl/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2010-08-26 15:58:33 -0700
committerIan Romanick <ian.d.romanick@intel.com>2010-09-03 11:55:21 -0700
commit9434a0749f26c640305f68ef85d17a31063a5705 (patch)
tree7b80754d50f94a56ad4ece84c4045b14aea9834f /src/glsl/Makefile.am
parent0f4f8c73644a9cc436500d605413207c44cfb4ee (diff)
glsl2: Add module to analyze variables used in loops
This is the first step eventually leading to loop unrolling.
Diffstat (limited to 'src/glsl/Makefile.am')
-rw-r--r--src/glsl/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/glsl/Makefile.am b/src/glsl/Makefile.am
index 5728a8b63d..55e4332af5 100644
--- a/src/glsl/Makefile.am
+++ b/src/glsl/Makefile.am
@@ -62,7 +62,8 @@ glsl_SOURCES = \
ir_to_mesa.h \
ir_validate.cpp \
ir_vec_index_to_swizzle.cpp \
- linker.cpp
+ linker.cpp \
+ loop_analysis.cpp
BUILT_SOURCES = glsl_parser.h glsl_parser.cpp glsl_lexer.cpp
CLEANFILES = $(BUILT_SOURCES)