summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 10e0bd47ab..af5a5fdc4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -911,9 +911,18 @@ if test "x$enable_egl" = xyes; then
SRC_DIRS="$SRC_DIRS egl"
EGL_LIB_DEPS="$DLOPEN_LIBS -lpthread"
EGL_DRIVERS_DIRS=""
- if test "$enable_static" != yes && test "$mesa_driver" != osmesa; then
+ if test "$enable_static" != yes; then
# build egl_glx when libGL is built
- EGL_DRIVERS_DIRS="glx"
+ if test "$mesa_driver" != osmesa; then
+ EGL_DRIVERS_DIRS="glx"
+ fi
+
+ # build egl_dri2 when xcb-dri2 is available
+ PKG_CHECK_EXISTS([x11-xcb xcb-dri2 xcb-xfixes],
+ [have_xcb_dri2=yes],[have_xcb_dri2=no])
+ if test "$have_xcb_dri2" = yes; then
+ EGL_DRIVERS_DIRS="$EGL_DRIVERS_DIRS dri2"
+ fi
fi
fi
AC_SUBST([EGL_LIB_DEPS])
@@ -1315,7 +1324,7 @@ AC_ARG_ENABLE([gallium-nouveau],
[enable_gallium_nouveau=no])
if test "x$enable_gallium_nouveau" = xyes; then
GALLIUM_WINSYS_DRM_DIRS="$GALLIUM_WINSYS_DRM_DIRS nouveau"
- GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS nouveau nv04 nv10 nv20 nv30 nv40 nv50"
+ GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS nouveau nv30 nv40 nv50"
fi
dnl
@@ -1395,7 +1404,11 @@ dnl Libraries
echo ""
echo " Shared libs: $enable_shared"
echo " Static libs: $enable_static"
-echo " EGL: $enable_egl"
+if test "$enable_egl" = yes; then
+ echo " EGL: $EGL_DRIVERS_DIRS"
+else
+ echo " EGL: no"
+fi
echo " GLU: $enable_glu"
echo " GLw: $enable_glw (Motif: $enable_motif)"
echo " glut: $enable_glut"