summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-16 12:30:07 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-16 12:30:07 +0000
commit3e06e4cec64dd8fa896c8a989f7fffdb6fa91b82 (patch)
treed566c094ee311ef624e7dad2bbc46ae996687c76
parent3ff43a6838a6a67d58513ac47b2fe68b0f1d6713 (diff)
DOWNLOAD: don't use := assignment for function implementation
:= causes the function parameters to get evaluated at definition time instead of implementation time, which is kind of silly for a function. Fixes make source-check / external-deps
-rw-r--r--package/Makefile.autotools.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index bd8bed4bb..6753f68b1 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -134,7 +134,7 @@ TERM_RESET := $(shell tput rmso)
# support make source-check/external-deps
ifneq ($(SPIDER),)
-DOWNLOAD:=$(WGET) -P $(DL_DIR) $(1)/$(2)
+DOWNLOAD=$(WGET) -P $(DL_DIR) $(1)/$(2)
else
define DOWNLOAD
$(Q)test -e $(DL_DIR)/$(2) || \