summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2009-01-21 13:33:21 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2009-01-21 13:33:21 +0000
commit87d040ee5038e7cec53e4bce6df9aa3ee6d2dbeb (patch)
tree763f3d3fe3da59fc83c9c480dc78ef7dbe0ab9fa
parent6e20da741b77f3e5c9b8a96e3101fcc4ab9cfee2 (diff)
package/multimedia/gst-plugins-good/gst-plugins-good.mk
package/multimedia/gst-plugins-good/Config.in gst-plugins-good does not build unless some package dependencies are forced. This patch allows you to turn off some of the plugins with these dependencies and hides others that require some packages (like PNG/JPEG) Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
-rw-r--r--package/multimedia/gst-plugins-good/Config.in22
-rw-r--r--package/multimedia/gst-plugins-good/gst-plugins-good.mk33
2 files changed, 55 insertions, 0 deletions
diff --git a/package/multimedia/gst-plugins-good/Config.in b/package/multimedia/gst-plugins-good/Config.in
index 22241d54f..e36ccdad5 100644
--- a/package/multimedia/gst-plugins-good/Config.in
+++ b/package/multimedia/gst-plugins-good/Config.in
@@ -72,6 +72,7 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_LEVEL
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MATROSKA
bool "matroska"
+ depends on BR2_PACKAGE_BZIP2 && BR2_PACKAGE_ZLIB
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MONOSCOPE
bool "monoscope"
@@ -119,4 +120,25 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPARSE
bool "wavparse (*.wav audio)"
default y
+comment "plugins with external dependencies (more to come)"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX
+ bool "annodex (XML Library)"
+ default y
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ESD
+ bool "esdsink (ESounD sound daemon)"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_JPEG
+ bool "jpeg (JPEG support)"
+ depends on BR2_PACKAGE_JPEG
+ default y
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS
+ bool "ossaudio (OSS audio)"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_PNG
+ bool "png (PNG support)"
+ depends on BR2_PACKAGE_LIBPNG
+ default y
endif
diff --git a/package/multimedia/gst-plugins-good/gst-plugins-good.mk b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
index bef8d01b0..c120edbb3 100644
--- a/package/multimedia/gst-plugins-good/gst-plugins-good.mk
+++ b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
@@ -142,6 +142,7 @@ endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MATROSKA),y)
GST_PLUGINS_GOOD_CONF_OPT += --enable-matroska
+GST_PLUGINS_GOOD_DEPENDENCIES += zlib bzip2
else
GST_PLUGINS_GOOD_CONF_OPT += --disable-matroska
endif
@@ -236,4 +237,36 @@ else
GST_PLUGINS_GOOD_CONF_OPT += --disable-wavparse
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-annodex
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-annodex
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ESD),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-esd
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-esd
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_JPEG),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-jpeg
+GST_PLUGINS_GOOD_DEPENDENCIES += jpeg
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-jpeg
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-oss
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-oss
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_PNG),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-png
+GST_PLUGINS_GOOD_DEPENDENCIES += libpng
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-png
+endif
+
$(eval $(call AUTOTARGETS,package/multimedia,gst-plugins-good))