summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-27 15:10:45 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-27 15:10:45 +0000
commit7603183a87b0144cbcfde662aec90520ab94958e (patch)
treedfe60f3393bc42b512c1fd7cbdbf26791486ce92
parent5ef9e52b8e370677df4fbe69b94c5cfd59bb5a8a (diff)
- put dependency checking right to the start where any later stages can rely on the being ok.
-rw-r--r--Makefile2
-rw-r--r--toolchain/uClibc/uclibc.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 8cf088821..cf1593d89 100644
--- a/Makefile
+++ b/Makefile
@@ -213,7 +213,7 @@ $(TARGETS): $(BASE_TARGETS)
dirs: $(DL_DIR) $(TOOL_BUILD_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
$(BINARIES_DIR) $(PROJECT_BUILD_DIR)
$(BASE_TARGETS): dirs
-world: dirs target-host-info $(TARGETS)
+world: dependencies dirs target-host-info $(TARGETS)
.PHONY: all world dirs clean dirclean distclean source target-host-info \
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 256d2ee70..54d788f7d 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -359,7 +359,7 @@ endif
UCLIBC_TARGETS=$(TARGET_DIR)/lib/libc.so.0
endif
-uclibc-configured: dependencies kernel-headers $(UCLIBC_DIR)/.configured
+uclibc-configured: kernel-headers $(UCLIBC_DIR)/.configured
uclibc: $(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-gcc $(STAGING_DIR)/usr/lib/libc.a $(UCLIBC_TARGETS)