summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-07-24 13:38:39 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-07-24 13:38:39 +0000
commitbcad6288f5f23229677a63e3ccea65093efcb933 (patch)
tree6eb57249e8ed9e01e3751ccd9d91808d2c76b5e7
parent0770fcc8a01ab3a2ed9f11ecb73d8a59dc3b7f5b (diff)
Makefile.autotools.in: fix make source-check/external-deps differently
The MAKELEVEL test is not that robust; It fails with the recent log support or if buildroot is driven from an external Makefile. Rework it to instead detect source-check/external-deps by the fact that they set SPIDER.
-rw-r--r--Makefile2
-rw-r--r--package/Makefile.autotools.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c23ec7160..8cadf5c3a 100644
--- a/Makefile
+++ b/Makefile
@@ -350,7 +350,7 @@ _source-check:
external-deps:
@$(MAKE) -Bs BR2_WGET=$(TOPDIR)/toolchain/wget-show-external-deps.sh \
- source
+ SPIDER=--spider source
#############################################################
#
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 16fc37192..5e94b447e 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -131,7 +131,7 @@ TAR ?= tar
# Retrieve and unpack the archive
$(BUILD_DIR)/%/.stamp_downloaded:
# support make source-check/external-deps
-ifeq ($(MAKELEVEL),1)
+ifneq ($(SPIDER),)
$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE)
$(if $($(PKG)_PATCH),$(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_PATCH))
else